Server desync/ghosting/bases taking an eternity to load is still a thing (but only for specific people, apparently?)

So yeah, 3+ "networking patches" in and this is still a thing. It makes the game pretty much unplayable, and seems to happen on every populated server I play on. And while it only seems to affect some people, it's not exactly rare either. Search for 'desync' here or on the steam forums and you'll see dozens of posts by people afflicted by it.

To clarify, this isn't the run-of-the-mill rubberbanding and lag that's affecting everyone; this is a problem where the client just flat out gives up the ghost on updating certain players – other people around you will be playing just fine, while you're stuck in dial-up hell. The most obvious way to tell you have it is if resources don't disappear on mining them, like you see above, but NPCs also continue to lag-teleport all over the place despite appearing fine for others.

I get that it's EA and I don't mind waiting for light at the end of the tunnel, but I'd love some kind of response from Funcom that they're at least aware this problem – again, SEPARATE from the lag others are experiencing – exists, and if they offered some kind of explanation as to what is going on. I cannot for the life of me figure out why the game should be laggier for certain individuals than others. My connection is rock solid everywhere else. Some people have suggested it's bandwidth related, but I've watched my network utilization while playing and I don't ever see the game use more than 6-10KB/s upstream. So what the hell is going on here? I'm starting to suspect there's something deeply wrong with the way the game handles server to client communication.

edit: Forgot to mention that I wasn't having this problem on any of the servers I tried yesterday, including ones with 60 players, and was able to play on one without it happening for several hours. Now, however, all populated servers I've tried are back to having the same issue, including ones that were fine yesterday. This and the fact the game isn't coming anywhere close to maxing out my bandwidth makes me think it's not a connection issue.

Leave a Reply

Your email address will not be published. Required fields are marked *