[Megathread] Feedback/Suggestions/Bugs


Hello Ghosts,

as the full game is already released in some parts of the world, we would like you to let us know what you think should be improved, changed or added into the game.

We have decided to divide this thread into 3 main categories:

1. Feedback

2. Suggestions

3. Bugs

Please, when posting, make sure to include as much information as possible, and if you can, provide screenshots or videos as well.

I will update the list based on your posts as often as possible.

Thank you.


1. Helicopter & Airplane handling

  • helicopter handling is still problematic and frustrating. <
    This does not match with the gunsmith view (the gunsmith view is correct); and where it is mounted in 3rd person ingame, is a hinged cover to allow access to the weapon's gas parts. This is wrong.
    In the most basic of field cleaning, this rail cover would be opened a lot. We would never mount a sight there, as we'd be there all day zeroing the damn thing again. Source: British Army, SAA Instructor (Inf).

2. Character/slot bug

  • when using the second or third save slot, I can't see the character, he is hidden behind the customization menu to the left.

3. Xbox One – Scroll bug

  • If I scroll too far down into locked accessories (hats for example) I lose control of the menu entirely. The only way to regain it is to back all the way out to the first customization page.

4. PC – Vehicle Chat is bugged

  • in PC mode the vehicle chat is still bugged. As in, if you open the chat to type a message while entering a vehicle, you cannot cancel or send the message. Instead all keys still register (typing Go! Throws a grenade) but you cannot send it.

5. Push to talk doesn't work in drone or any vehicle

  • I've noticed consistently whenever I'm in drone or any vehicle (Driver or pass) Push to talk doesn't work at all. Even tried changing the keybinding for push to talk to see if that'd fix it, and that was even worse. On foot with a different keybinding (Tab) push to talk activated one out of maybe ten times.

6. Xbox One – Silencer sound bug

  • when playing co-op with friends sometimes you will be using a silencer on your gun, but to your teammates you are loud and not using a silencer.

7. PC – Occasional in-game freezes

  • been experiencing momentary freezing while driving around. I haven't seen my FPS drop below about 70 so far on max settings, but every once in a while the game will freeze for 3-4 seconds while driving. The last time it happened I noticed it happened as the sky was changing from day to dusk.

8. DLC Sniper rifle the Stampede (Cowboy Lever Action) is not zero'ed

  • the DLC Sniper rifle the Stampede (Cowboy Lever Action) is not zero'ed at all. Shots land 2-3 feet above the target at 100 meters. I believe the iron sights are not aligned, because third person it is fine.

9. Picked up sniper rifle not actually suppressed

  • when you pick up a sniper rifle off a downed enemy it won't be suppressed. You can put a suppressor on and it sounds suppressed on your side but the enemies and other players in your game will hear it as un-suppressed so it will alert enemies

10. Convoy bug/misdesign

  • when doing a Story Mission or anything else, once a Convoy passes by you and gets triggered, it fails once the Convoy gets away and interrupts your current mission, forcing a reload, resetting your progress. This mostly happens when getting El Polito's car and the Convoy Story Mission hasn't been done yet. It's pretty random, but every Convoy in the game interrupts what you do, some routes are very close to other missions, thus it can get very frustrating.

11. Xbox One – Lost ability to take cover / auto-cover system not working.

  • this bug is massively infuriating. Not sure if it's tied to when you get downed or have to respawn, most times it's happened has been after I've done this. It seems to only happen to me in multiplayer only. It feels like it only happens after exiting a vehicle though, I haven't noticed it after getting revived.

12. Clothing Bug

  • Multicam shading is not consistent across outfit components – the crye precision shirt is properly shaded but the pants, packs, and helmets/hats are all brighter/unshaded. Also some camouflages are not placed or sized correctly (for example 3-color DCU), and also when you use camouflage on shirt, it is always darker than the same camouflage used on your pants, creating big contrast and unrealistic effect.

13. Resource tagging

  • If you die while tagging a resource then upon your potential revival, you and your teammates can tag that resource again.

14. Player/vehicle/swimming animation issue

  • players may see another player running alongside or atop a vehicle when they're actually sitting inside the vehicle. The player affected will not see this effect. It seems to occur when someone has previously died in a vehicle. Similar to the vehicle bug, the swimming animation may bug so that other players see another player as constantly swimming (with water trails from each stroke and everything). This occurred after I parachuted into a river and was only visible to my teammates.

15. The Deluxe Edition shotgun bug

  • the Deluxe Edition shotgun has a misaligned ironsight. Your arms clip into your face as you aim your shotgun and the gun is centered on-screen – as if you were in the original Doom.

16. Enemies don't seem to mind or notice that you turned the power off

17. Vehicles only kill players when they reach a certain speed. Aside from that, they do no damage

18. Ubisoft rewards not unlocking

  • Ubisoft Rewards are not unlocking for some actions – for instance, reviving a teammate hasn't unlocked despite me reviving multiple teammates.

19. Xbox One – Wet bug

  • When I was playing last night with three friends, three of us became al glossy like we were wet but, there was no rain happening. Only one person on our team was able to see the rain and he wasn't even the host of the session.

20. PS4 – HUD bug

  • when you turn off the "Notifications" HUD, the prompt to choose which intel to gather disappears.

21. Mission "Rebell Rising" bug

  • When you replay the Mission "Rebell Rising" it will instandly say mission complete and switches to the next one, this is a big problem because I cant progress with my friend who needs this mission.

22. PC Auto-Save causing freezing

  • Every single time the game auto-saves while I'm in a vehicle, or flying, I get a 3-5 second graphics freeze. Followed by a hard rubberband for any passengers. I've read several threads about this and there is no solution yet. The game is installed on a SSD, and I've got a gtx1070… This needs to be fixed.

23. Stoner LMG folded buttstock nowhere to be found

  • Stoner LMG folded buttstock nowhere to be found, it says San Mateo, but it's not anywhere on the map for this specific weapon.

24. PS4 – Intel Bug

  • Major Intel not appearing when entering the province of Montuyok.

25. Drone flying into heli bug

  • Flying a drone into a helicopter's blades causes a lot of damage and will usually one hit kill Little Birds. This can easily happen when deploying drones from a passenger seat. You have to hold the down button to stop it from flying up.

26. Destroyed convoys can still be tagged

27. Playing for a long time (hours) will break some game features

  • vehicle radios stop playing music, missions may break. The third sub mission in the east had the sub not spawn until we restarted the mission.

28. El Cerebro's assistant refuses to get into his car if you restart the mission

  • he just stands there. Sometimes he'll fake get in by pretending to open the door and then sitting in mid air before standing again. In addition, you pass by a Unidad base whose soldiers can spot you and fail the mission, forcing you to restart the game.

29. The laser on the stoner lmg does not show up or give an option to turn on or off

30. MK17 Bug

  • When using the MK17 it has the extended mag showing in the gun when I have the standard mag equipped. IMO the extended mag looks ugly on the MK17 so I only use the standard mag on it, but it still shows the extended mag in game and it's driving me insane.

31. 3 round burst bug

  • There is a bug with 3 round burst resulting in a dead trigger (click to fire, nothing happens). I've only tested this on the G36C. This is on PC.

32. Tac-map bug

  • When one of your teammates puts a way-point on a gun or part, you cannot tell what it is when you hover over it in the TAC-MAP.

33. Map glitch

  • Fallen through the map multiple times. Walking around on rocky hillsides is extremely glitchy. Respawn points for certain camps/missions are terrible and make you walk hella far around a rocky structure.

34. PS4 Bug – Unidad patrol level

  • I can't see the Unidad patrol level on my HUD. It displays correctly in the factions tab.

35. The M1891 Nagant incorrectly has a straight bolt

  • it should have a bent bolt to fit under the scope when cycled.

36. AUG Bug

  • The 20 round magazine of the AUG looks like a 30 round magazine and the 30 round magazine looks like (I think) a 50 round magazine (which makes the magazine look unnecessarily long)

37. SASG-12 Bug

  • The SASG-12s 30 round mag looks ridiculous. Just replace the model with a drum and it should be fine (I also think that the magazine that's portrayed ingame is a 20 round magazine and not 30)

38. Xbox – XP Bug

  • I can gain XP, or at least it shows that I am getting it but my blue bar is maxed out at level 6 and will not let me progress to any higher levels. Is anyone else having this issue? I didn't have my XP progress bar for the HUD turned out originally so I didn't even notice this but I have already played about 18 hours worth and have around 25 skill points unused and really do not want to start over.

39. Drone/Binoculars bug

  • Sometimes after parachuting or bailing from a destroyed helicopter, I cannot use drone or binocs for an extended amount of time.

40. The hybrid scope bug

  • if I switch weapons and switch back, the hybrid scope would be flicked into position while zoomed out at the same time (as if the scope wasn't flicked into position) . Pressing the hybrid scope button makes the character flick an invisible scope back up to zoom it back in. I don't know if that makes sense, it's like the game forgets to keep the scope on the side if I keep it in red dot view.

41. Female shaggy hair + goggles = ADS bug

  • playing as a female with shaggy hair and goggles sometimes cause your hair to cover you scope when ADS.

42. PC- Unable to complete side missions / gather intel etc.

  • when locating intel or interrogations that are not part of main quest line, player animates like he is photographing / talking to target item/person but stays frozen in that state until right mouse button is clicked. Intel is not obtained or gathered. This may be related to the UI as I have most HUD elements off.

43. Xbox One – Deluxe edition characters

  • I cannot see/use Mountain or Wolf even though it was shown as being "unlocked in CharacterSmith".

44. Rebels should not be able to kill a target while I'm interrogating them

45. Crosshair shows one area where you bullet is supposed to fly to, when zoomed into iron sights – you will hit different spot

46. PS4 Gold Edition (digital download) – Infinite Booster issue

  • is having a wide spread issue with the Infinite Booster. Some users report no problems, some had it working and it timed out, and some users have never had it active at all. By the time the bug gets fixed, it won't be beneficial.

47. Fast travel gets rid of whatever gun you have and if it is not "owned"

48. Xbox Gold Edition (Digital) it didn't award any store credits

  • Xbox Gold Edition (Digital) it didn't award any store credits, nor does it show I have the season pass. When I go to the Xbox store on the console. It says Gold Edition wasn't purchased. Even though I was clearly charged. This has happened to lots of people.

49. Weapon Optic Bug – Micro T1 & G33 magnifier

  • When using the Micro T1 & G33 magnifier the HUD will display 3x in the lower left corner, when the magnifier is pushed to the side and you're actually viewing at 1x. Then when utilizing the magnifier the HUD will display 1x. The optic functions fine it's just the information on the HUD is reversed. I was using the 556xi when I noticed it.

50. PC Controller Bug

  • when using controller on PC. Pressing A on the map brings up the notification center. Makes it so that you cannot fast travel while using a controller.

51. Weapon accuracy is degraded when utilizing the Blackhawk mini-guns as the pilot

  • whatever weapon is your primary will be considered when shooting the helicopter mini guns.

52. Fix enemy AI spawn trapping me when I use fast travel to spawn

  • Please fix enemy AI spawn trapping me when I use fast travel to spawn into a location or when I respawn from death… It's game breaking! There is always enemy AI killing me over and over… 🙁 PS4 v4.50/game update 1.02

53. There is no reload sound effect for the Scorpion Evo SMG

54. HTI and the MK14 share a common ammo pool which makes no sense

  • I just realized the HTI and the MK14 share a common ammo pool which makes no sense because they are different calibers and I need different extended magazines for them yet shooting one depletes the magazine or the other!

55. Helicopter supply raids bug

  • helicopter sometimes spawn below the ground on the helipad. Able to go in but unable to fly. System : PS4

56. Got El Sueno's "SILENCIO", died and got revived and now it's permanently unsuppressed. Can't change it in loadout either

57. The 7.62 (30 round) extended mag for guns such as the AK-12 and 556XI is blocked

  • The 7.62 (30 round) extended mag for guns such as the AK-12 and 556XI is blocked for me. I've gone to the location with a friend (Friend A) who also didn't have it, they could pick it up but I couldn't. Another friend (Friend B) who we were playing with also had the same issue as me, we both think it's because both me and Friend B picked up the 50 round (7.62 mm) extended mag the previous day, Friend A wasn't in that prior game and didn't already have the 50 round mag.

58. Xbox One – Helicopter randomly refuses to downthrottle

  • When I hold RT, the chopper ascends. When I hold LT, it's supposed to descend/slow down, but it also ascends. It was working fine, I wasn't shot, didn't hit an obstacle, tried to descend and it just wouldn't let me. I tried switching seats and then back to the pilot's seat. Didn't work. Had to parachute out.

59. The missile warning sound bug

  • I had a bug where the missile warning sound kept going even there was no missile and I was not even in a heli. Tried dying, fast travel, booted game, booted PC but it still kept going and it sure was annoying af. I got rid of it by finding a heli and finding a anti-air to shoot me down.

60. Rebels not spawning in game when starting up at the rally point

  • for example I am at faction level 17. When I was at level 16. There would be at least 12 people at my rally point and constant rebels driving through the map. I ranked up to level 17, rally points are full of green dots and map covered in green cars. Once I am done playing for the day, save the game, exit out. I log back into the game next day, my rally point has zero rebels. It seems like the game thinks my faction level is at zero. Seems like a error in the loading time or just a delayed process because they will start to show up 30 minutes into the game.

61. Auto-cover sometimes stops working

  • confirmed by multiple people (op included), should be high priority.

62. Blood pools after eliminating enemies are not appearing

63. Can't do takedowns on sleeping enemies

64. Xbox One – Gunner reticle bug

  • If you in a gunner position (either truck or helicopter) if you go to the menu and you return to action your reticle disappears.

65. When I was swimming the other day my other AI teammates were literally walking on water

66. Enemies hitboxes

  • when enemies are crouching behind cover but their heads stick out from the side of it, their heads don't seem to have working hit boxes as sniper rounds do absolutely nothing.

67. Destroying a convoy truck while grabbing the driver leaves a dead driver standing upright

68. Task Force Player Tag Bug

  • Tags are appearing as a set of random numbers rather than the designated four character tag.

69. Xbox One: Teammate volume does not work

70. Quinoa Plant conversation bug

  • every time I die/load into an area, I have to listen to the Quinoa Plant conversation. I did the mission yesterday, and now that soundbite plays literally every single time I deploy/load/etc.

71. Map glitch

  • not sure the implications but a spot by island if you jump off rock in the water instead of hitting water it sends into parachute mode and you free fall under water as under the map! Its wild and deploy parachute and glide under the lake but no water visible just the deep bottoms of map. Eventually it unharnessed me and I began walking everywhere but couldn't find a way back up but could have walked forever. I tried again and it worked no problem again.

72. The flashbangs seem to be buggy or broken

  • so many times i have thrown them at a group of enemies all standing within the radius and either only one or none at all get stunned.

73. Drone & Binoculars randomly stops working until you fail the mission or quit to main menu

74. Progression bug: EXP bar stuck at Level 7

75. AI teammates abruptly lose sync shot mark, forcing enemies into alert mode

76. Gamebreaking bug on Xbox One – Pucara

  • been in and out of the Pucara province, gotten all collectables, restarted the game several times, tried joining multi-player games and the first Intel video to start the story missions in the province won't pop up. AKA: I can't do any main missions in Pucara because I haven't been introduced to the buchon yet and I haven't been able to get the conversation to trigger.

77. Flare bug

  • the flare of the signal pistol seems only to be shown to the one shooting it, not to the teammates.

78. Explosives delay

  • All explosives in the game seem to suffer from some sort of major lag issues at times. I've had C4 and grenades just sit there for a while well after they should have exploded. The most frustrating thing is the underbarrel grenade launcher is near useless against moving vehicles because the hit doesn't register half the time and several seconds there is just an explosion where the vehicle used to be.

79. Guns not loading into game

  • Fairly often when joining a co-op game your character will be holding nothing but have his/her hands in a position as if they are holding an invisible gun. It may take several minutes before they finally do pop in. This also seems to come with huge desync with enemy location and sometimes making you immune to all damage while everything is still slowly loading in. My wife joined me once and we tried defending a rebel radio and she had no gun, could take no damage, and she could not see the enemies in the same spot as me at all. But she could heal me if I fell…. So that was nice I guess.

80. Headset bug

  • When I equip "Headset D" (As I have purchased the Doorkickers pack from the Store), it automatically unequips it and reverts my character back to wearing "Earpiece". I select Headset D, go back to the Accessories menu, and it's like I never selected it. Every other item I've purchased works but that one. This only happens when equipping facewear with the Patrol cap and any headset. Any goggles/masks + Patrol cap + headset = Headset automatically unequipped, despite the preview showing just fine.

81. The scopes on the SVD are not aligned properly

  • the bullets are offset to the right where the scopes are pointed on most scopes and at least one is to the left of the crosshair.

82. PC – The motorbike controls cannot be changed for left and right

  • I do not use WASD, so I'm using RDFG, and despite being able to map buttons on every other vehicle to RDFG, the motorbike will remain mapped to RADF – not easy to drive that way I'm afraid!

83. Windows 10 – Mic Bug

  • If you mute the microphone in-game it will mute it permanent on Windows 10.

84. Boats get halfway submerged when driving around in them

85. PS4 – M4A1 Bug

  • I wanted to look at the damage meter changes between silencer on and off on my M4A1. I push the touch pad to go to menu, go to Loadout tab to see the meter with silencer on. Now back to my actual game screen, I press L2 to aim, press up arrow to take silencer off. Press touch pad, go to Loadout tab, read the meter. Then when I exit out back to Bolivia, my character just reloads out of nowhere as if I have an empty mag. So I repeat. Silencer back on, go to Loadout, then back out. It reloads again. If I do this 5 times straight, I will run out of ammo.

86. C4 and possibly other throwables bug

  • You can throw C4 and possibly other throwables through thin objects by orienting your character so that the arm goes through the object when it releases the throwable.

87. You can hear players walking when they're still in a post-mission cutscene in a safehouse

88. Players are unable to shoot out of trunks, AI players can

89. Heli > water bug

  • If you land a helicopter in the water the engine will continue to run normally, even after it sinks. Being in the water doesn't seem to cause any damage or ill effects whatsoever.

90. Parachuting bug

  • Every now and then when I jump out of a chopper to parachute, I get stuck in the air, after my chute deploys. I just sit there floating.

Last updated: 26/03/2017 12:05 CET

Original post

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.